+ New Ticket

Query timeout

Comments

12 comments

  • Official comment
    Avatar
    Aleksander Vinokur

    Hello Santhosh,

    Could you provide the Workbench log file after reproducing the issue? Please follow the next steps:
    1. Go to Help menu -> Show Log file.
    2. Scroll to the bottom, hit enter enter enter, then type 'START' enter enter enter, and then save the log.
    3. Do the thing that is causing trouble
    4. Attach or send us the log (preferably as a .txt) to support@aginity.com.

    This will help us try to isolate exactly what is happening when you experienced the problem.

    Regards,

    Alex.

    Comment actions Permalink
  • Avatar
    eric.aduda
    Hi, Has anybody found a fix for the timeout error. All my sessions that run longer 120 seconds are timing out. thanks, Eric
    0
    Comment actions Permalink
  • Avatar
    Eli Weine

    Hi All - we are currently working on a fix to the query timeout issue.  I'll update this thread with an ETA on the fix once we have it scheduled.  Thanks for your patience.

    0
    Comment actions Permalink
  • Avatar
    Orrin Watson

    I found the following URL, which claims to help by replacing one of the underlying DLLs:  http://www.bigdatamark.com/fixing-query-timeout-aginity-workbench/

    0
    Comment actions Permalink
  • Avatar
    Eli Weine

    Workbench for Hadoop version 4.6 solves the timeout issue.  You can find this and previous versions in the downloads section of the Workbench for Hadoop documentation here:  https://www.aginity.com/documentation/wb/ha/

    0
    Comment actions Permalink
  • Avatar
    Santhosh Meenhallimath

    Hi,

    I am getting the timeout error when I run any query which runs more than 120 sec.

    I changed the settings in Tools>>Options->Genderal->Default Query timeout to 0.

    I am using Version 4.8.0.2551(build 6/14/2016)

    Any fix ???

    Thanks in advance

     

     

     

    0
    Comment actions Permalink
  • Avatar
    Richard Wallach

    Is there a fix for the Redshift version?  Same issue there.

    Rich

    0
    Comment actions Permalink
  • Avatar
    Bertrand Blanc

    +1 for Redshift .. I am unable to run a query longer than 3600 seconds and it seems impossible to override that value.

    thank you

    Ber

    0
    Comment actions Permalink
  • Avatar
    Eli Weine

    Bertrand, what is your statement_timeout setting in Redshift?

     

    http://docs.aws.amazon.com/redshift/latest/dg/r_statement_timeout.html

     

    My guess is it is set to 3600000.  Workbench will not override the cluster-side setting.  

    0
    Comment actions Permalink
  • Avatar
    Bertrand Blanc

    Hello Eli,

     

    as mentionned in the link you pasted (thank you by the way), statement_timeout has 0 as default value.

    In my case, this statement wasn't modified, so it value stay to 0 by default.

    WLM configuration time out value is also set  to 0.

    Thanks,

    Bertrand.

    0
    Comment actions Permalink
  • Avatar
    Atnafu Dargaso

    Timeout issue with Aginity workbench for Hadoop

    Version 4.9.1.2686 (build 05/11/17)

    3600000 sec for Tools>>Options->Genderal->Default Query timeout

    why is that happen?

    0
    Comment actions Permalink
  • Avatar
    Eli Weine

    1000 hours! For such a large timeout value, use a Tools>>Options->Genderal->Default Query timeout value of 0. 

    (0 = unlimited)

    To see what may cause your timeout you can view the Workbench log. Help -> Show Log File and search from the bottom up for "timeout". The message in this log is returned by the ODBC driver and may or may not provide good insight.

    For further details, you can inspect the log in the hive.server2.logging.operation.log.location

    Last, you can refer to following links to understand various configuration parameters in Hive and their values:

    https://cwiki.apache.org/confluence/display/Hive/AdminManual+Configuration

    https://cwiki.apache.org/confluence/display/Hive/Configuration+Properties

     

    0
    Comment actions Permalink

Please sign in to leave a comment.