+ New Ticket

Netezza Missing ODBC Driver Files

Comments

13 comments

  • Official comment
    Avatar
    Eli Weine

    Hi Greg, you will need to download a Netezza JDBC driver and then point Aginity Pro to this driver. Unfortunately, we are unable to provide IBM drivers with the product for legal reasons. We suggest you get the proper JDBC driver from your DBA(s). The IBM site can be very difficult to navigate to find what you need.

    Once you get the proper driver, you can follow the instructions here to upload it and move forward :)

    Comment actions Permalink
  • Avatar
    Greg Brown

    Update:  I got Netezza JDBC drivers installed and configured and it's working great now,  thank you for pointing me in the right direction.   

    PS:  Kudos to whoever developed the query tab names and I laughed out loud at work when I opened Preferences and saw the toggle for "Boring tab names"!  Made my day :)

    0
    Comment actions Permalink
  • Avatar
    Priyanka Girdhar

    Hi,

    I could not open the link shared by Eli to upload the drivers.

    I am facing the same issues, if anybody can help here.

    0
    Comment actions Permalink
  • Avatar
    George L'Heureux

    Hi Priyanka!

    Try following the instructions in our Aginity Pro documentation here: https://aginity-documentation.readthedocs.io/projects/aginity-pro/en/latest/docs/connections/configure_connections/#downloading-drivers

    Thanks for being part of the Aginity community!

    George from Aginity

    0
    Comment actions Permalink
  • Avatar
    Priyanka Girdhar

    Hi George,

    Thanks for quick response.

    I checked the same link earlier as well. But that does not give full info

    Issue I am facing is -->

     "This driver has no driver files yet.  Use edit drivers to add them".   I click on "edit drivers" and I get a pop-up to add files, but I don't know what files it wants?

    And there is no option of Custom / Provided for Netezza Driver option.

    I installed ODBC AND JDBC Drivers both in my system.

    0
    Comment actions Permalink
  • Avatar
    Emirhan Yeniçeri

    in my computer they're installed in "C:\JDBC" folder.

    name of the jar file is "nzjdbc"

    0
    Comment actions Permalink
  • Avatar
    Priyanka Girdhar

    Thanks Emirhan , its working now.

    0
    Comment actions Permalink
  • Avatar
    George L'Heureux

    I'm glad you got it working - thanks Emirhan for helping out a fellow user!

    George from Aginity

    0
    Comment actions Permalink
  • Avatar
    Christopher Meringolo

    I'm having the same issue once I have upgraded to Aginity Pro. It worked fine on the previous version of Aginity. I can't find the ODBC driver file it's looking for anywhere and I know I have it installed. Does anyone know where it is typically saved and what the filename is?

    0
    Comment actions Permalink
  • Avatar
    Sergey Vishnevskiy

    Hi Cristopher,

    Please, take a look at Eli's answer which is the first answer in the thread. Use this link https://documentation.aginity.com/projects/aginity-pro/en/latest/docs/connections/configure_connections/#manually-add-drivers instead of the link provided by Eli.

    0
    Comment actions Permalink
  • Avatar
    Christopher Meringolo

    Hey Sergey - I understand how to add the netezza driver. My question was, where do I find the netezza driver I have installed so that I can add it to Aginity. 

    0
    Comment actions Permalink
  • Avatar
    Jeff Schlitt

    Chris,

     

    If you are using Aginity Pro it uses JDBC not ODBC so you are looking for the driver nzjdbc3.jar or nzjdbc.jar.   If you search your hard drive it may have been installed when you installed the client tools for Netezza.  If not you'll need to contact your Netezza DBA and ask him for the JDBC driver installer.  IBM does not let us distribute the drivers which is why you need to "hunt" this one down.

    Once you get the driver you can follow Sergey's instructions for adding.

     

    Hopefully this helps.

    0
    Comment actions Permalink
  • Avatar
    Christopher Meringolo

    Thanks Jeff! I believe I only have the ODBC driver installed and that's my issue. I'll get the JDBC driver installed and give it another shot.

    0
    Comment actions Permalink

Please sign in to leave a comment.